SpaceExplorer and Siemens NX 8.5: buttons not working

Questions and answers about 3Dconnexion devices on Windows.

Moderator: Moderators

rbird7
Posts: 4
Joined: Mon Jan 06, 2014 7:48 am

SpaceExplorer and Siemens NX 8.5: buttons not working

Post by rbird7 » Mon Jan 06, 2014 8:15 am

I use Siemens NX 8.5 and driver 6.17.7 on W7-x64. Rotating the model using the SpaceExplorer works fine, but the preconfigured buttons do not (at least most of them). Button "1" activates the numeric pad and also transfers the entered value to NX correctly. Also the CTRL button on the spaceexplorer in combination with the "F" button on the keyboard activates "Fit" as expected. But the predefined "Fit" button does not work. Using the "3Dx Button Mapping Editor" I assigned "File-Open" to the fit-button, but NX does not seem to accept this either (and I haven't found any command that does work). The same issue also appears on other workstations with another SpaceExplorer. Any clues?

Barbara
Moderator
Moderator
Posts: 534
Joined: Fri May 14, 2010 11:11 am

Re: SpaceExplorer and Siemens NX 8.5: buttons not working

Post by Barbara » Mon Jan 06, 2014 11:53 am

Hello rbird7 -

Check 3DxNX in your NX main menu to see if "Button Mapping Editor" and "Device Settings" are greyed out. If they are, it means the the system environment variables need to be edited. The steps here show what needs to be done for each version of NX on the PC.

When there is more than one version of NX installed, the environment variables for each NX installation need to be adjusted so that they correctly point to the path for 3dxnx.dll. Environment variables are located on the Advanced tab in System Properties. When you re-start NX after making the changes for each NX version installed, you should find the 3DxNX items available and commands mapped to your buttons able to generate.
------------------
Barbara

rbird7
Posts: 4
Joined: Mon Jan 06, 2014 7:48 am

Re: SpaceExplorer and Siemens NX 8.5: buttons not working

Post by rbird7 » Tue Jan 07, 2014 12:15 am

BTW: the 3DxWare.log file has the following error (multiple times):
16:8:44.694: SendKey.dll:SendKeys: Error 0x5 from SetWindowsHookEx

rbird7
Posts: 4
Joined: Mon Jan 06, 2014 7:48 am

Re: SpaceExplorer and Siemens NX 8.5: buttons not working

Post by rbird7 » Tue Jan 07, 2014 12:22 am

Hi Barbara,

No the 3DConnexion menu is not greyed out and I can actually launch the 3Dx Button Mapping Editor from there. I can also assign another command to the FIT button as described, but that doesn't work. So I haven't made any changes to the environment variables.

Cheers,

Brett
Posts: 5
Joined: Mon Feb 24, 2014 10:17 pm

Re: SpaceExplorer and Siemens NX 8.5: buttons not working

Post by Brett » Mon Feb 24, 2014 10:34 pm

I've gone to my global system environment variables, and there is no "UGII_3DCONNEXION_LIBRARY" variable.
Do I need to create one? If so, what is the Value?

Thanks

UtaSH
Moderator
Moderator
Posts: 3276
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: SpaceExplorer and Siemens NX 8.5: buttons not working

Post by UtaSH » Tue Feb 25, 2014 3:09 am

Hello Brett,

with the latest driver 3DxSoftware 3.17.8 the variable UGII_3DCONNEXION_LIBRARY isn't set anymore in the system, but in your ugii_env.dat file.

Do you have problems with the buttons?

Brett
Posts: 5
Joined: Mon Feb 24, 2014 10:17 pm

Re: SpaceExplorer and Siemens NX 8.5: buttons not working

Post by Brett » Tue Feb 25, 2014 2:59 pm

Yes, since upgrading to NX9, I can't program the buttons using the 3D mouse editor on my desktop, and Customize buttons is greyed out on the 3Dconnexion tab in NX.

I can use the mouse to control the view, as usual, but the buttons aren't working, except for getting the number pad up when I press 1.

UtaSH
Moderator
Moderator
Posts: 3276
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: SpaceExplorer and Siemens NX 8.5: buttons not working

Post by UtaSH » Wed Feb 26, 2014 6:49 am

Which version of the driver do you have installed?

Have you done a new installation or a repair of the driver software after you upgraded your NX?

Brett
Posts: 5
Joined: Mon Feb 24, 2014 10:17 pm

Re: SpaceExplorer and Siemens NX 8.5: buttons not working

Post by Brett » Wed Feb 26, 2014 3:46 pm

I have the latest driver - 3.17.8

I'll try doing a clean install.

Brett
Posts: 5
Joined: Mon Feb 24, 2014 10:17 pm

Re: SpaceExplorer and Siemens NX 8.5: buttons not working

Post by Brett » Wed Feb 26, 2014 4:28 pm

OK, I did a clean install, but customize buttons is still greyed out in NX9

UtaSH
Moderator
Moderator
Posts: 3276
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: SpaceExplorer and Siemens NX 8.5: buttons not working

Post by UtaSH » Thu Feb 27, 2014 9:56 am

I think we now need a log file from your NX. :-)

I'll provide you with an email address where to send it to.

Chadron
Posts: 1
Joined: Fri Mar 14, 2014 8:56 am

Re: SpaceExplorer and Siemens NX 8.5: buttons not working

Post by Chadron » Fri Mar 14, 2014 9:02 am

any update on this? i am having the same problem. Space explorer itself works, but none of the buttons work and i cannot program them. i am running NX9 on windows 7.

UtaSH
Moderator
Moderator
Posts: 3276
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: SpaceExplorer and Siemens NX 8.5: buttons not working

Post by UtaSH » Mon Mar 17, 2014 3:17 am

Hello Chadron,

yes, the user had his own ugii_env.dat file and the entry that is made by our software during the installation wasn't in this file. If you have the same issue please check if you are using the default ugii_env.dat file (usually located in the folder 'UGII' of your installation folder of NX). If you have your own file you have to add this line

Code: Select all

UGII_3DCONNEXION_LIBRARY=${UGII_BASE_DIR}\ugalliance\vendor\startup\3dxnx.dll
to the file.

If this information does not help please let me know.

berdir
Posts: 3
Joined: Mon Apr 28, 2014 12:48 pm

Re: SpaceExplorer and Siemens NX 8.5: buttons not working

Post by berdir » Mon Apr 28, 2014 12:57 pm

Hello UtaSH,

I'm facing the same problem as described above and i've tried all the fixes.
me and 50 colleagues would like to know how to fix the customize buttons functionality in NX9.0.1

Our systems all run windows 7 Enterprise
the problem occurs both in NX native environment as in managed mode via teamcenter.

I've already contacted the Siemens helpdesk and they have send some dll's with adjustments but without succes.

the 3Dconexxion hardware we used:
- space pilot pro
- space pilot
Attachments
Capture.PNG
screenshot of the ribbon bar
Capture.PNG (22.68 KiB) Viewed 16576 times

UtaSH
Moderator
Moderator
Posts: 3276
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: SpaceExplorer and Siemens NX 8.5: buttons not working

Post by UtaSH » Tue Apr 29, 2014 9:17 am

Hello berdir,

which driver version do you have installed?

I recommend to use either 3DxSoftware 3.17.8 or 3DxWare 10.0.22 (the driver for the SpaceNavigator).

It is important that the environment variable UGII_3DCONNEXION_LIBRARY is set. This is usually done in the file ugii_env.dat, but you might have your own customized one. Please check. If you have problems to find out let me know.

Post Reply