"old" SpaceNavigator issues

Questions and answers about 3Dconnexion devices on Windows.

Moderator: Moderators

Post Reply
goalposthead
Posts: 3
Joined: Sat May 18, 2019 6:27 am

"old" SpaceNavigator issues

Post by goalposthead » Sat May 18, 2019 6:36 am

Hi. I am facing several issues. I probably should start by mentioning that my SpaceNavigator is not compatible with the current firmware updates, which clearly marks it as an older model (3dx-600028).
I often experience problems with it everytime W10 makes updates involving .NET and this has been going on since the dreaded Anniversary Update. I have tried everything including using differend drivers versions but it keeps acting nonetheless.
I use it specifically with one platform, which is Daz Studio. As things are now, I can't tilt my camera sideways, even with that axis ticked in the settings UI.

Am I doomed to purchase a newer model?

aalsalihi
Posts: 20
Joined: Mon Apr 15, 2019 9:14 am

Re: "old" SpaceNavigator issues

Post by aalsalihi » Mon May 20, 2019 7:29 am

Hi Poalposthead,

Did you try to test it in our Viewer ? Does it have the same issues there as well ?

Will be waiting for some updates on your end to move forward.

Thanks
Abdul. A

goalposthead
Posts: 3
Joined: Sat May 18, 2019 6:27 am

Re: "old" SpaceNavigator issues

Post by goalposthead » Tue May 21, 2019 5:08 am

Hi :)
The turbine in the viewer won't even rotate. One symptom I should also point out is that after some of those windows updates, opening anything that works with the spacenavigator will show a spinning or drifting in the viewport.

aalsalihi
Posts: 20
Joined: Mon Apr 15, 2019 9:14 am

Re: "old" SpaceNavigator issues

Post by aalsalihi » Wed May 22, 2019 6:51 am

Hi goalposthead,

So the SpaceNavigator not working in the viewer as well??
For drifting issues, you could try to Calibrate the device. Follow the steps here: https://www.3dconnexion.com/faq/35

Thanks
Abdul. A

goalposthead
Posts: 3
Joined: Sat May 18, 2019 6:27 am

Re: "old" SpaceNavigator issues

Post by goalposthead » Fri May 24, 2019 6:49 am

Hi aalsalihi,
All in all (I really have to come back to this) all my troubles started after W10 got its "anniversary" update. I have tried about everything, calibration included, as well as trying different versions of the driver. My device's firmware is outdated and cannot be updated either.
In the Viewer, the spacenavigator isn't working. It works in demos like Jet, though.

Post Reply