SpaceMouse Pro - Issues with custom button setup

Questions and answers about 3Dconnexion devices on Windows.

Moderator: Moderators

Post Reply
lardbros
Posts: 4
Joined: Fri Jan 20, 2017 5:20 am

SpaceMouse Pro - Issues with custom button setup

Post by lardbros » Mon Feb 18, 2019 4:04 am

Hi there,

I've been using my Space Mouse Pro for years, but don't tend to bother with custom button setups.
Only recently have I decided to set a couple of handy buttons up for my software, but they only work properly for one session. (A session being until I close the application and start it again.)

When I say the customisation stops working, the button does BUT... the custom button setup UI still shows my chosen shortcuts set for the right buttons, so they're being saved correctly. But they still seem to function as the default choices.

My setup is as follows:
- I've changed the '1' button to be Spacebar
- I've changed the '2' button to also be Spacebar (this was to determine what was the issue)
Like I said above, this works for one session in each application.

These are still listed as correct shortcuts in the UI for 'Buttons', but whenever I press the '1' key I STILL get the annoying Numpad. It's like these are hardwired or something? The 3d Connection Drivers display the correct software as being

If I go in and re-add the buttons I want, it then works again for the current session.

Any chance this can be looked into? It's rather frustrating. :(
It seems this is only when using LightWave 3d, 3ds Max recalls the buttons correctly. Any ideas?

Hardware: HPZ820, GeForce RTX 2080Ti, Spacemouse Pro
Software: Win 7 64-bit Enterprise (we have roaming profiles, whether this makes any difference?), 3dxWare 10.5.12, LightWave 3d 2019

UtaSH
Moderator
Moderator
Posts: 3237
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: SpaceMouse Pro - Issues with custom button setup

Post by UtaSH » Tue Feb 19, 2019 3:47 am

Hello lardbros,

I recommend that you contact our Technical Support Team. They will need a log file of the driver and your user specific configuration files for more details.

trogul
Posts: 1
Joined: Tue Apr 23, 2019 7:07 am

Re: SpaceMouse Pro - Issues with custom button setup

Post by trogul » Tue Apr 23, 2019 7:20 am

Hi UtaSH,

I am struggeling with the exact same issue on my Space Mouse PRO Wireless. I just updated my driver to the latest driver 10.5.15, without any success and issue is still present. When changing button setup, it works fine for one session and then it is being reset to default.

A quick "GOOGLE", shows that this has been problem for quite some time now, as users are reporting back in time as long as August 2017. They report that there were an earlier driver that this worked on. Please advice on which driver that this problem is fixed. This should be a quick fix for you guys! :?


Regards,
Trond Brekke Gulvik

Post Reply