SpaceNavigator under RHEL 5.6

Questions and answers about 3Dconnexion devices on UNIX and Linux.

Moderator: Moderators

Post Reply
oz
Posts: 4
Joined: Mon Aug 29, 2011 12:40 am

SpaceNavigator under RHEL 5.6

Post by oz » Mon Aug 29, 2011 12:46 am

Hi,

I am trying to install the SpaceNavigator on a RHEL 5.5 workstation.
If I start the driver as root, I can run xcube as a normal user. The driver is spawned normally true init, however, then users can't use the driver, they get an error:
user@wumc0345 ~ > xcube
No driver is running. Exit ...

as root you can see I have the latest driver version:
wumc0345 ~ # /etc/3DxWare/daemon/3dxsrv -v
3DxWareUNIX = V1.5.3, ID 6913

wumc0345 ~ # cat /tmp/3DxWare.log
3DxWareUNIX V1.5.3 ID 6913 log file
Process ID: 4893
Time: 2011-08-25 15:40:16
Machineinfo 1: Systemname=Linux, Nodename=wumc0345, Release=2.6.18-194.17.4.el5
Machineinfo 2: Version=#1 SMP Mon Oct 25 15:50:53 EDT 2010, Machine=x86_64
Runlevel-Info: run-level 5 May 12 09:07 last=S
-----------------------------------

[2011-08-25 15:40:16] uddev.c, 711: UdDevInit() 0x9f38010
[2011-08-25 15:40:17] 3dxsrv.c,806: displayname = $DISPLAY set to :0
[2011-08-25 15:40:17] 3dxsrv.c,811: putenv() was successful
[2011-08-25 15:40:17] 3dxsrv.c,813: displayname is now :0
[2011-08-25 15:40:18] auth.c :: authGetUser(), FOUND: user home = "/home/seltsam"
[2011-08-25 15:40:18] 3dxsrv.c :: startupInittab(), authGetUser(), user=seltsam
[2011-08-25 15:40:18] UdDev: Opening USB device on USB port /proc/bus/usb/001/030
[2011-08-25 15:40:18] UdDev: Opening SpaceNavigator on USB port /proc/bus/usb/001/030
[2011-08-25 15:40:18] snav_usb.c :: UdDevRezero(): Rezeroing the device
[2011-08-25 15:40:18] snav_usb.c :: UdDevSetDeadband(): Setting deadband to 26
[2011-08-25 15:40:18] 3dxsrv.c,831: UdDevOpen() was successful [SpaceNavigator]

in the logs of the machine I see:
/var/log/messages:

Aug 25 15:29:34 wumc0345 kernel: usb 1-2.1.4: usbfs: process 3196 (3dxsrv) did not claim interface 0 before use
Aug 25 15:29:34 wumc0345 gconfd (seltsam-31387): Received signal 15, shutting down cleanly
Aug 25 15:29:34 wumc0345 gconfd (seltsam-31387): Exiting
Aug 25 15:29:51 wumc0345 init: Re-reading inittab
Aug 25 15:30:15 wumc0345 init: Re-reading inittab
Aug 25 15:30:16 wumc0345 kernel: usb 1-2.1.4: usbfs: process 3263 (3dxsrv) did not claim interface 0 before use


Any ideas why I can't make the driver spawn so that normal users can user it?

UtaSH
Moderator
Moderator
Posts: 3289
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: SpaceNavigator under RHEL 5.6

Post by UtaSH » Mon Aug 29, 2011 8:16 am

Hi oz,

does the driver start from the /etc/inittab if you do a
  • xhost +
Can you provide a log file from a driver start from the /etc/inittab? Please change the entry in the /etc/inittab to:
  • 3d:2345:respawn:/etc/3DxWare/daemon/3dxsrv -d usb -debug -E </dev>/dev/null 2>&1
Make sure the file has a current date.

oz
Posts: 4
Joined: Mon Aug 29, 2011 12:40 am

Re: SpaceNavigator under RHEL 5.6

Post by oz » Tue Aug 30, 2011 1:03 am

UtaSH wrote:Hi oz,

does the driver start from the /etc/inittab if you do a
  • xhost +
Hi Uta,
yes the driver starts. In fact, as I wrote the drive is always present. Here is an example:

Code: Select all

wumc0345 ~ # pgrep 3dxsrv
24671
wumc0345 ~ # kill 24671
wumc0345 ~ # pgrep 3dxsrv
24797
wumc0345 ~ # #process respawned ...
wumc0345 ~ # xhost +
access control disabled, clients can connect from any host
wumc0345 ~ # pgrep 3dxsrv
24797
wumc0345 ~ # kill 24797
wumc0345 ~ # pgrep 3dxsrv
24813
wumc0345 ~ # #process respawned ...
wumc0345 ~ # xcube
No driver is running. Exit ...
UtaSH wrote:Hi oz,

Can you provide a log file from a driver start from the /etc/inittab? Please change the entry in the /etc/inittab to:
  • 3d:2345:respawn:/etc/3DxWare/daemon/3dxsrv -d usb -debug -E </dev>/dev/null 2>&1
I already did in my first post...

UtaSH
Moderator
Moderator
Posts: 3289
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: SpaceNavigator under RHEL 5.6

Post by UtaSH » Tue Aug 30, 2011 1:34 am

Hi oz,

so if you have the entry in the /etc/inittab active the driver window opens?

Did you check if the process number of the 3dxsrv process is always the same (if you don't kill it :-) )?

Do you get several logfiles if you change the entry in the /etc/inittab to:
  • 3d:2345:respawn:/etc/3DxWare/daemon/3dxsrv -d usb -debug -E -multiLogs </dev>/dev/null 2>&1

oz
Posts: 4
Joined: Mon Aug 29, 2011 12:40 am

Re: SpaceNavigator under RHEL 5.6

Post by oz » Tue Aug 30, 2011 2:28 am

UtaSH wrote:Hi oz,
so if you have the entry in the /etc/inittab active the driver window opens?
what is the "driver window" ?
the only way I test it now is xcube, other applications obviously fail to work with the mouse.
Did you check if the process number of the 3dxsrv process is always the same (if you don't kill it :-) )?
when do user logs out, the process is killed, and restarted, so the pid is not the same after logout, relogin ...
Do you get several logfiles if you change the entry in the /etc/inittab to:
  • 3d:2345:respawn:/etc/3DxWare/daemon/3dxsrv -d usb -debug -E -multiLogs </dev>/dev/null 2>&1
I am only getting this:

Code: Select all

 wumc0345 ~ # ls /tmp/*log
/tmp/3DxWare.log  /tmp/ks-script-7WlDcr.log

UtaSH
Moderator
Moderator
Posts: 3289
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: SpaceNavigator under RHEL 5.6

Post by UtaSH » Wed Aug 31, 2011 6:52 am

oz wrote: what is the "driver window" ?
There should be a window "3DxWare 1.5.3" that is the control panel for the driver. Our driver is not a kernel driver, but running in user space. Do you have that window?
oz wrote: the only way I test it now is xcube, other applications obviously fail to work with the mouse.
What other applications did you try? The xcube only starts if it finds the window of the driver.
oz wrote: when do user logs out, the process is killed, and restarted, so the pid is not the same after logout, relogin ...
Yes, when a user logs out the driver is killed and then re-started from the init process. I was just interested if it keeps the same process number when you do not kill it and do not log out.
oz wrote: I am only getting this:

Code: Select all

 wumc0345 ~ # ls /tmp/*log
/tmp/3DxWare.log  /tmp/ks-script-7WlDcr.log
Please launch a
  • init q
after you made changes to the /etc/inittab. Otherwise the 3dxsrv process will not be restarted with the new options. (You need root privileges for this command.)

Post Reply