problème d'install sous ubuntu

Questions and answers about 3Dconnexion devices on UNIX and Linux.

Moderator: Moderators

wakinyann
Posts: 7
Joined: Wed Jan 30, 2008 7:31 am

problème d'install sous ubuntu

Post by wakinyann » Wed Jan 30, 2008 7:37 am

Bonjour à tous,
En suivant la doc, je n'arrive pas à installer spacenavigator sur ma ubuntu (en root). En tout cas les demos ne fonctionnent pas...
Comment peut on verifier que l'installe c'est bien passé ?
merci d'avance

UtaSH
Moderator
Moderator
Posts: 3258
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: problème d'install sous ubuntu

Post by UtaSH » Thu Jan 31, 2008 4:10 am

Bonjour wakinyann,

apres l'installation il y a un dossier /etc/3DxWare avec les fichiers necessaires. Le pilote est /etc/3DxWare/daemon/3dxsrv.

Est-ce-que tu a une entree dans /etc/inittab pour l'appel du pilote? S'il n'y a pas une entree tu peut demarrer le pilot avec:

/etc/3DxWare/daemon/3dxsrv -d usb

Quel est le message d'erreur des demos?

wakinyann
Posts: 7
Joined: Wed Jan 30, 2008 7:31 am

Post by wakinyann » Thu Feb 07, 2008 1:41 am

Merci uludwig pour votre réponse.
J'ai en effet une entrée dans mon inittab.
Pour ce qui est des demos, elles ne se lancent pas. Mais peu importe. Ce qui m'interesse c'est de faire fonctionner spacenavigator sous Blender... et là avec la version http://www.blenderbuilds.com/2007/08/05 ... h-a-prize/
ça n'a pas l'air de fonctionner...

UtaSH
Moderator
Moderator
Posts: 3258
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Post by UtaSH » Thu Feb 07, 2008 4:08 am

Salut wakinyann,

en premier il nous faut decouvrir pourquoi les demos ne fonctionnent. Ensuite le prochain pas sera Blender.

Est-ce qu'il y a un processus du pilote actif? (ps -edf | grep 3dxsrv)
Tu peut desactiver l'entree du /etc/inittab en changer le mot "respawn" a "off". (avec root privileges)

Code: Select all

3dx:234:off:/etc/3DxWare/daemon/3dxsrv -d usb </dev>/dev/null 2>&1
Maintenant tu peut demarrer le pilote d'un terminal.

Code: Select all

/etc/3DxWare/daemon -d usb
Publie ici le message d'erreur, s'il te plait.

Si le pilote fonctionne correctement Blender peut-etre fonctionnait aussi?

wakinyann
Posts: 7
Joined: Wed Jan 30, 2008 7:31 am

Post by wakinyann » Thu Feb 07, 2008 5:44 am

après avoir desactivé le pilote dans inittab
lorsque je lance (terminal sous root) /etc/3DxWare/daemon/3dxsrv -d usb
j'ai le message "commande introuvable"

UtaSH
Moderator
Moderator
Posts: 3258
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: "commande introuvable"

Post by UtaSH » Thu Feb 07, 2008 9:07 am

Il semble que les fichiers du pilote n'existent pas. :?
Controle si le dossier /etc/3DxWare existe et s'il ya le dossier daemon avec le ficher 3dxsrv dedans.
En cas ces n'existent pas, installe le pilote de nouveau.

Encore les memes problemes?

wakinyann
Posts: 7
Joined: Wed Jan 30, 2008 7:31 am

Post by wakinyann » Fri Feb 08, 2008 1:00 am

/etc/3DxWare/daemon/3dxsrv existe bien.
et dans 3DxWare j'ai les fichiers suivant :
4DNav.scg
CADDS_R13.scg
CADDS_R14.scg
CatiaV4_01.scg
CatiaV5_01.scg
CatiaV5_02.scg
CatiaV5_03.scg
daemon
default_10.scg
default.scg
DMUNav.scg
DVise.scg
Enovia_VPM.scg
ICEM_MED.scg
IDEAS_01.scg
Patran_01.scg
ProEWildfire_01.scg
ProEWildfire_02.scg
readme.3dxware
UGSNX2_01.scg
UGSNX2_02.scg
UGSNX3_01.scg
UGSNX3_02.scg
UGSNX4_01.scg
UGSNX4_02.scg

UtaSH
Moderator
Moderator
Posts: 3258
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Post by UtaSH » Fri Feb 08, 2008 3:42 am

D'accord.
Quel est l'édition (output) des commandes suivants: :?:

Code: Select all

cd /etc
ls -lR 3DxWare

Code: Select all

cd /etc/3DxWare/daemon
file 3dxsrv
./3dxsrv -version

Code: Select all

md5sun /etc/3DxWare/daemon/3dxsrv

wakinyann
Posts: 7
Joined: Wed Jan 30, 2008 7:31 am

Post by wakinyann » Fri Feb 08, 2008 3:54 am

1ere commande :

Code: Select all

3DxWare:
total 660
-rw-r--r-- 1 root root 26481 2008-01-30 15:21 4DNav.scg
-rw-r--r-- 1 root root 25745 2008-01-30 15:21 CADDS_R13.scg
-rw-r--r-- 1 root root 25601 2008-01-30 15:21 CADDS_R14.scg
-rw-r--r-- 1 root root 26015 2008-01-30 15:21 CatiaV4_01.scg
-rw-r--r-- 1 root root 26580 2008-01-30 15:21 CatiaV5_01.scg
-rw-r--r-- 1 root root 26578 2008-01-30 15:21 CatiaV5_02.scg
-rw-r--r-- 1 root root 26488 2008-01-30 15:21 CatiaV5_03.scg
drwxr-xr-x 2 root root  4096 2008-02-08 11:38 daemon
-rw-r--r-- 1 root root 25871 2008-01-30 15:21 default_10.scg
-rw-r--r-- 1 root root 25867 2008-01-30 15:21 default.scg
-rw-r--r-- 1 root root 26573 2008-01-30 15:21 DMUNav.scg
-rw-r--r-- 1 root root 25977 2008-01-30 15:21 DVise.scg
-rw-r--r-- 1 root root 26023 2008-01-30 15:21 Enovia_VPM.scg
-rw-r--r-- 1 root root 25788 2008-01-30 15:21 ICEM_MED.scg
-rw-r--r-- 1 root root 26893 2008-01-30 15:21 IDEAS_01.scg
-rw-r--r-- 1 root root   359 2008-02-08 08:59 listing.txt
-rw-r--r-- 1 root root 25881 2008-01-30 15:21 Patran_01.scg
-rw-r--r-- 1 root root 26026 2008-01-30 15:21 ProEWildfire_01.scg
-rw-r--r-- 1 root root 26065 2008-01-30 15:21 ProEWildfire_02.scg
-rw-r--r-- 1 root root  6832 2008-01-30 15:21 readme.3dxware
-rw-r--r-- 1 root root 25889 2008-01-30 15:21 UGSNX2_01.scg
-rw-r--r-- 1 root root 25869 2008-01-30 15:21 UGSNX2_02.scg
-rw-r--r-- 1 root root 25972 2008-01-30 15:21 UGSNX3_01.scg
-rw-r--r-- 1 root root 25981 2008-01-30 15:21 UGSNX3_02.scg
-rw-r--r-- 1 root root 25937 2008-01-30 15:21 UGSNX4_01.scg
-rw-r--r-- 1 root root 25965 2008-01-30 15:21 UGSNX4_02.scg

3DxWare/daemon:
total 296
-rwxr-xr-x 1 root root 297015 2008-01-30 15:21 3dxsrv
2eme commande :

Code: Select all

3dxsrv: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), for GNU/Linux 2.2.5, dynamically linked (uses shared libs), not stripped

Code: Select all

root@wakinyann-laptop:/etc/3DxWare/daemon# ./3dxsrv -version
./3dxsrv: error while loading shared libraries: libXm.so.3: cannot open shared object file: No such file or directory
3eme commande :

Code: Select all

root@wakinyann-laptop:/# md5sum /etc/3DxWare/daemon/3dxsrv
887e92d5709370df6db2fa5341dffe0f  /etc/3DxWare/daemon/3dxsrv

UtaSH
Moderator
Moderator
Posts: 3258
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Post by UtaSH » Fri Feb 08, 2008 4:38 am

Aaah! Enfin!
Avec le message complète je peut aider. :D

Il manque le libmotif. Il est dans le progiciel "openmotif" où "lesstif". S'il te plaît utilise le programme "synaptic" pour installer l'un des deux.

Pourrait être que tu doit créer un lien d'un libXm existant à libXm.so.3.

wakinyann
Posts: 7
Joined: Wed Jan 30, 2008 7:31 am

Post by wakinyann » Fri Feb 08, 2008 5:55 am

ça fonctionne à present.
merci infiniment

christopher
Posts: 2
Joined: Sat May 10, 2008 6:57 am

Post by christopher » Sat May 10, 2008 8:09 am

j'ai moi même ce problème, à la différence que lesstif est bien installé. De plus je ne trouve pas lesstif dans le gestionnaire de paquets.... j'ai la dernière version d'ubuntu et je ne veux pas revenir sur windows... :cry:

christopher
Posts: 2
Joined: Sat May 10, 2008 6:57 am

Post by christopher » Sat May 10, 2008 8:17 am

désolé j'ai fait une erreur dans le dernier message je ne trouve pas openmotif dans le gestionnaire... :wink:

UtaSH
Moderator
Moderator
Posts: 3258
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Pas d'OpenMotif

Post by UtaSH » Mon May 26, 2008 9:59 am

Salut christopher,

désolée pour répondre si tardive. Je crois qu'il faut désinstaller lesstif et puis installer openmotif. :?:

Uta Ludwig
3Dconnexion

sgalland
Posts: 15
Joined: Thu Jul 10, 2008 11:39 pm
Location: Belfort, France
Contact:

Re: Pas d'OpenMotif

Post by sgalland » Tue Jul 22, 2008 6:12 am

uludwig wrote:Salut christopher,

désolée pour répondre si tardive. Je crois qu'il faut désinstaller lesstif et puis installer openmotif. :?:

Uta Ludwig
3Dconnexion
Bonjour,

Il est nécessaire, sur les dernières Ubuntu, d'installer libmotif3.

Je suis le responsable d'un paquet Ubuntu/Debian pour 3DxWare. Il est disponible sur www.arakhne.org.
Ce paquet réalise toutes les actions d'installation.

Stéphane
Dr. Stephane GALLAND

Systems and Transport Lab.

Post Reply